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Release Notes

Introduction

These release notes contain important information about usability enhancements and resolved issues in Sage 100 
ERP Intelligence Reporting 7.3.1. The notes within this document highlight the changes made between the release of 
Sage 100 ERP Intelligence Reporting 2013 and 2014. The Sage 100 ERP Intelligence Reporting release is focused 
on features which aim to improve the usability of the solution.

New Features 

New Metadata Repository
As of the Sage 100 2014 release, when the software is run for the first time, the user will now be prompted to enter a 
new metadata repository location.

When Sage 100 2014 is open, only the latest reports will be available in the system. If the user would like to access 
their customized reports from Sage 100 2013. They will be required to export their reports from Sage 100 2013 and 
import them into Sage 100 2014. 

Support for Citrix and Terminal Services Load Balanced Environments

Official support for Citrix and Terminal Services load balanced hosted environments has now been added in the form 
of additional configuration settings which can configure Sage Intelligence to run in a behaviour required specifically 
when using Sage 100 ERP Intelligence Reporting within a secured load balanced hosted environment.

NOTE: This support only applies to versions of Sage 100 ERP Intelligence Reporting which have been configured to 
have their licensing handled using the Integrated License Manager depicted below. 

Location: Config.ini settings file.
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New Switches Now Supported within Config.ini File

The following configuration switches are now supported within Sage 100 ERP Intelligence Reporting’s Config.ini  
settings file:
DisableAddConnections
DisableViewConnectionProps
MaxCubeDimensions
HideReportRepositoryPath
HideTemplateStorageLocation

Support for Simplified Chinese Windows 7 OS

Sage 100 ERP Intelligence Reporting now functions correctly (in English) on Windows 7 with a Simplified Chinese 
Language Pack installed and Simplified Chinese MS Excel.

UI Modernization
Easy Access to Commonly Used Report Manager Features

Report Manager Menu items have been restructured and grouped to enable users to easily identify the features that 
they wish to utilize. The more commonly used menu items are now accessible from the Home and Help tabs.  
All existing functionality and business logic remain as in prior versions of Sage 100 ERP Intelligence Reporting.

The Home tab contains further logical grouping of features, including Action  
functions and Report functions. 

Location: Report Manager > Home

The ‘Actions’ grouping contains functions that allow the user to manage reports within the Report Manager module 
and include the following existing Report Manager features:
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 • Copy     • Add Report
 • Move To    • Rename
 • Paste     • Delete
 • Add Folder    • Refresh

The Report grouping has functions that allow users to perform operations on reports within the Report Manager  
module and includes the following existing features:

 • Run     • Lock/Unlock Report
 • Design    • Run Sample
 • Save Excel Template   • Check/Test
 • Create Shortcut   • History

All icons on the Home tab ribbon are visible in windowed mode.

Location: Report Manager > Home

The Help tab contains features from the existing help drop down menu which are aimed at assisting the user by  
directing them to the help file and online communities as well as providing information on the product:

 • View Help
 • Website
 • Online Academy
 • Knowledge Base
 • About
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Location: Report Manager > Help

Easy Access to Less Commonly Used Report Manager Features

The Report Manager’s less commonly used menu items are now accessible from the File and Tools tabs.   

The File tab has been visually aligned to a more familiar interface for a File Menu item and contains further  
logical grouping of existing features including Configure Internet Connection and Metadata Options. Metadata Op-
tions allows the user to backup Metadata and Templates, change their Metadata Repository as well as compacting 
their Metadata to improve performance.

Location: Report Manager > File

The Tools tab contains further logical grouping of features, including Report functions and System functions. All icons 
on the Tools tab ribbon are visible in windowed mode.
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Location: Report Manager > Tools

The Report functions grouping on the Tools tab includes the following existing report manager features which allow the 
user to perform more advanced management functions in the Report Manager:

• Import Report
• Export Report
• Output Mode
• Toggle Hidden Reports, previously labeled as Show/Hide Hidden reports 
• Scheduler Command
• Bulk Import/Update
• Run All Reports, previously labeled as Run Report Batch
• Clean Pivot fields
• Clear Report History, previously labeled as Purge Instance History

The System functions grouping on the Tools tab allows users to view System Variables, select a Tenant Cache option 
of open or clear, as well as Unlock Excel.

Easy Access to Commonly Used Connector Features

The Connector module boasts a new Ribbon feature with informative icons and labels for each feature promoting ease 
of use.
Connector Menu items have been restructured and grouped to allow users to more easily identify the features they 
wish to use. The more commonly used menu items are now accessible from the File, Home and Help tabs.  
Location: Connector > Home
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The Connector File tab has been visually aligned to a more familiar interface for a File Menu and contains further 
logical grouping of existing features including Configure Internet Connection and Metadata Options. Metadata Options 
allows the user to Backup Metadata and Templates, change their Metadata Repository as well as compacting their 
Metadata to improve performance.

Location: Connector > File

The connector Home tab contains further logical grouping of features, including Action functions, Expression functions, 
Data Container functions and Connection Functions. All icons on the Home tab ribbon are visible in windowed mode. 
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Actions Functions grouping includes basic container and expression management features allowing for the ability to:

 • Copy     • Sample Data 
 • Move To    • Rename 
 • Paste      • Delete
 • Check/Test    • Refresh

Expression Function grouping includes the ability to perform a Test Lookup for Expressions.

Data Container functions grouping allows users to modify containers’ expressions and includes the following existing 
Connector features:

• Add Expressions
• Dependencies
• Find and Replace
• Check/Test All Expressions
 
Connection function grouping enables modification of drivers and connections and includes the following existing 
features:

• Add Connection
• Add Data Container
• Driver Properties

The Connector Help tab aims to provide the user with informative resources which will guide the utilization and pro-
mote the understanding of the software. It contains features from the existing help drop down menu:

• View Help
• Website
• Online Academy
• Knowledge Base
• About

Location: Connector > Help
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Easy Access to Less Commonly Used Connector Features

The Connector’s less commonly used features are now accessible from the Tools tab in the new Connector Ribbon 
menu. All icons on the Tools tab ribbon menu are visible in windowed mode. The Tools tab contains further logical 
grouping of features, including Report functions and System functions which facilitate more advanced management 
within the Connector Module.

Location: Connector > Tools

Report feature grouping contains the existing Import Report feature.

The System feature grouping includes the following existing Connector features:
 
• Direct Query, previously labeled Direct Query Tool
• Configure Engine, previously labeled Configure Output Engine  
• System Variables
• Tenant Cache drop down with options of Open and Clear
• Log File drop down with options  of Open and Delete
• Update Metabase

Report Manager Background Change

The background of the Report Manager has been updated to promote a more modern and comfortable environment 
and align the system with Sage branding.
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Location: Report Manager > Run Report

Replace Configurable Icons with Professional Standard Icons

Certain icons within the system were previously configurable to each implementation, support for configuration of 
these icons has been removed and the icons have been replaced with newer, more professional looking icons to 
ensure a consistent look and feel of this application for users regardless of which integrated system they are using it 
with. Additionally the Menu bar and Home node icons have been standardized across all modules.

Location: Connector / Report Manager / Report Viewer /License Manager / OLAP Manager / Security Manager
Location: Windows Taskbar > Module Icons



Sage 100 ERP Intelligence Reporting
Release Notes

12

Enhanced Report Execution Progress Indicator

A new progress indicator has been implemented to replace the older styled moving icon, resulting in a more modern 
look and feel.

Improve Locked Report Properties Panel

The locked report screen and the ‘Unlock on Copy’ screen has been revamped to present information and instructions 
in a friendly and modern manner. This purpose of this revamp is to ensure users are not overburdened with informa-
tion they do not necessarily wish to see and regular users are presented with a more professional screen to encour-
age a more comfortable experience. 

Location: Report Manager > Right-click Report > Lock Report
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Location: Report Manager > Report > Properties Tab > Show Advanced Options > Check ‘Unlock on Copy’ > Right 
Click Report > Lock Report

Report Designer Add-In

The new Report Designer Add-in provides an enhancement to the Report Designer module which presents an  
alternative to the current report layout generator to empower users to take control of all design aspects of their  
reporting layouts.

The model behind the feature introduced by this add-in is to break down a report into reusable pieces and then allow 
users to control where and how these pieces fit together to create a report. These pieces are Excel functions which 
communicate with a new In-Memory processing engine which will guarantee performance by being able to crunch 
financial numbers very quickly. 

The diagram below depicts the positioning of the Report Designer Add-in.

Please review the Sage 100 ERP Intelligence Report Designer Add-In User Guide for guidance on how to use this 
add-in
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Improvements

Report Manager

Improved Behaviour of Report Property Columns
The tabs which appear when a report is selected within the report manager contain table grids to display data for 
columns, filters, parameters, sort fields and aggregate filters. The columns within these grids have been enhanced to 
automatically resize themselves to ensure they are displaying all text values fully. Previously if a text value was longer 
than the default column size it would be cut off, forcing a manual resize each time a tab was selected to view the text.

Location: Report Manager > Report > Columns / Filters / Parameters / Sort Fields / Aggregate Filters

Improved Reports Tree Header

Within the Report Manager, the reports listing tree previously displayed a header which was incorrectly sized and al-
lowed users to unnecessarily change the width of the viewable tree area. This header has been removed to promote 
a cleaner user interface and less confusion on how to change the width of the viewable tree area.
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Ability to Rename a Duplicate Container When Importing

When importing a report which contains a container with the same name as an existing container, the system will now 
allow the incoming container to be renamed. Previously the system would create a duplicate named container, making 
it challenging to identify the new container.

Location: Report Manager > Right-Click on Folder  > Import Report
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Location: Connector > Right Click on Connection > Import Report

Report Manager Folder Context Right-Click Menu Simplified

The Right-click menus in the Report Manager have been simplified to provide the user with a more concise list of op-
tions as well as option labels that are more informative. 
The Rick-click options “Run Report Batch”, “Run Report Batch (Mode 2)”, “Properties” and “Refresh” on the Folder 
Context right-click Menu have been removed to help simplify the list of relevant options available. The “Refresh” 
feature is still accessible in the Report Manager Ribbon via the Home tab and “Run Report Batch” and “Run Report 
Batch (Mode 2)” are available under the retitled ‘Run All Reports’ option under the Tools ribbon tab.

Location: Report Manager > Home > Right-Click Demonstration Folder 

Report Manager Report Context Right-Click Menu Simplified

The Right-click options “Run Sample” and “Refresh” on the Report Context right-click Menu have been removed and 
are now accessible in the Report Manager Ribbon via the Home tab. 
The Labels ‘Create and Link Template’ and ‘Purge Instance History’ have been replaced by less technical and there-
fore more easily understandable labels of ‘Save Excel Template’ and ‘Clear Report History’ respectively.
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Location: Report manager > Home > Right-Click Demonstration Folder 

Demonstration Reports

The Sage 100 ERP Intelligence Reporting Demonstration Reports have an updated look and feel.

Location: Report manager > Home > Demonstration > Financial Report Designer 2-6 > Run

 
Financial Report Designer 2-6
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Location: Report manager > Home > Demonstration > Management Pack D-2-6 > Run

Management Pack D-2-6

Location: Report manager > Home > Demonstration > RKL Analysis Dashboard 2-6 > Run

RKL Analysis Dashboard 2-6
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Location: Report manager > Home > Demonstration > RKL  Dashboard 2-4 > Run

RKL Dashboard 2-4

Location: Report manager > Home > Demonstration > Sales Details 2-2 > Run

Sales Details 2-2
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Location: Report manager > Home > Demonstration > Stock Re-order Levels 2-2 > Run

Stock Re-order Levels 2-2

Sage 100 ERP Intelligence Reporting Templates

Customer Sales Report 

A new Customer Sales template has been included which operates in the same way as the standard template how-
ever does not make use of the UQE.

Location: Report manager > Home > Sales > Customer Sales 2-7 > Run

Customer Sales 2-7
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GL Transactions Report 

A new GL Transactions report has been included which allows users to input Begin Date and End Date parameters.

Location: Report manager > Home > Financials > GL Transactions Report 2-5 > Run

GL Transactions Report 2-5

Report Designer Enhancements

The Report Designer user interface has been significantly improved within this release.

Ability to Maximize Report Designer Screen

The Report Designer window can now be maximized using the standard Windows maximize features. This allows  
users to take advantage of the full extent of their monitor’s size when designing financial reports. This change  
supports users in designing their reports faster and easier by showing more of report layout’s row and columns as well 
as making the various row and column options easier to select without repetitive scrolling.

Enhanced Report Designer Mapping Tool

Due to popular demand the Report Designer’s mapping tool has been enhanced within this release of Sage 100 ERP 
Intelligence Reporting with the most notable enhancement being the ability for end-users to natively add and delete 
Row Reporting Groups from within the Mapping Tool’s interface.
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Location: Run Report Designer Report with unmapped categories/accounts
Location: Select ‘Mapping Tool’ from BI Tools ribbon tab after running out a Report Designer Report

Row and Column Fields Now Alphabetically Ordered

Previously the available row and column options within the Report Designer were not ordered, sometimes making it 
difficult to find the right field quickly. This has changed and the available fields are now ordered alphabetically, 
allowing users to find what they need faster.
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Smoother Row and Column Dragging

The areas of the Report Designer which show the selected Rows and Columns have been improved to be smoother 
and much easier to use. Dragging rows or columns is now a far more pleasant experience allowing users to spend 
less time arranging their rows and columns. Additionally the scroll bar no longer allows users to scroll beyond their 
selected rows or columns making the process of moving columns or rows simpler.

Larger Fonts and Larger Row and Column Placeholders

The fonts used within the Report Designer have been enlarged to support increased readability and the placeholder 
bars within the selected row and column layout areas are now wider to accommodate longer field names and making 
existing layouts easier to read.

Ability to Insert Fields at Selection Point

The process of adding fields to existing report layouts has been made even easier with the ability to immediately insert 
row or column fields at a specific location within your layout. No longer do users need to insert a field to the end of the 
column or row layout area and then drag the field to their desired location - by simply selecting a field within the row or 
column layout areas, users can then select a field to be inserted next to their selection point, this includes spacers.

Quicker Loading Time

The Report Designer has been optimized to load up faster than ever before, ensuring there is no inefficient use of 
processor intensive graphics.
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Report Designer Layout Text Columns Auto-size

Previously any text columns placed into a Report Designer layout would not automatically size according to the con-
tent within them, usually needing users to manually resize the second column like account description. The need for 
this manual action has now been eliminated and the Report Designer now correctly sizes each text column according 
to the longest value that the field contains, saving you the time needed to resize manually.

Location: Generate a Report Designer layout with text columns.

Minor Mapping Tool User Interface Update

The Mapping Tool has been improved with a more descriptive explanation of the purpose of the Mapping Tool; re-
search showed that new users often did not necessarily understand the reason for this tool popping up the first time a 
Report Designer report is run. Each of the column lists has been widened to accommodate longer values and the help 
icon has been enlarged and now links directly to an improved help file topic on the Mapping Tool instead of only pop-
ping up a basic textbox. 

In addition, a selected item within the ‘Unmapped Categories’ list would previously lose its highlight once focus was 
given to another list on the form – this has now been resolved and the item retains its highlight, making this form 
easier and faster to use.
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Report Viewer Usability

Sage 100 ERP Intelligence Reporting includes the following usability enhancements to the Report Viewer module. 

• The Report Viewer remains open after selecting to run a report thereby allowing users to run multiple reports without 
  having to reopen the Report Viewer
• Report Viewer window size persistence has been introduced
• A minimum window size has been enforced to ensure that all available reports are visible

Location: Report Viewer > Demonstration 

Security Manager

Sage 100 ERP Intelligence Reporting includes an enhancement to the Security Manager module to display the user 
input for setting new and updating existing passwords in asterisk and not in plain text.
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Location: Security Manager > Add User 
Location: Security Manager > Change Password

Mapping Tool

Based on requests to give users more control of the Row Reporting Groups that the Report Designer uses to group 
GL accounts on a layout, end-users can now take full control of their reporting layouts by adding their own new  
reporting groups and deleting existing reporting groups.
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Mapping Tool ‘Group from’ and ‘Group into’ Fields Now Visible

The Mapping Tool now shows very clearly that it has been configured to use predetermined fields from within your Re-
port Designer report to perform mappings. The objective of showing the Group from and Group into fields is to ensure 
users understand that the ‘Available Categories’ field list can be sourced from different fields within your report, like 
Account Number for example (allowing you to map account numbers to Row Reporting Groups instead of mapping 
standard grouping categories to Row Reporting Groups)

Mapping Tool section within Help File Improved

The Mapping Tool section has been reviewed and improved to ensure that the users can get access to the correct 
level of detail if required. Additionally, instructions on how to configure the mapping tool to use different ‘Group from’ 
fields have been added to the same help file topic.

Performing Mappings Now No Longer Mandatory Upfront

Previously users were forced to map their Available Categories to Row Reporting Groups before being allowed to 
run out Report Designer Reports. This rule has now been relaxed in favour of explaining the purpose of the Mapping 
Tool clearly and then giving users more control over when they would like to approach the design of their reports. The 
Mapping Tool can then be accessed via the BI Tools Ribbon tab once the report has run out into MS Excel.
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Improved Performance

The Mapping Tool now maps categories to Row Reporting Groups faster than ever, as we opened up the ability for 
users to add their own Row Reporting Groups we also made sure the Mapping Tool’s internal logic was reviewed to 
handle larger amounts of Row Reporting Groups even quicker.

Multi-Language Support

Excel Components Now Support Multi-Language Implementation

All component located under the ‘BI Tools’ tab within Excel (Report Designer, Tools, Distribution) have been upgraded 
to support the implementation of different languages. Previously these components only supported being deployed in 
English. This change will significantly decrease the time needed to implement this application in different languages. 
*NOTE* These Excel components do not yet support implementations of all Unicode languages. Currently only French 
is fully supported, as more languages are implemented and tested – they will be fully supported.

Support for Excel 2010 64 Bit Edition

Sage 100 ERP Intelligence Reporting is now compatible with the 64 bit edition of Microsoft Excel 2010. Processors 
that are 64-bit are becoming the standard for systems that range from servers to desktop computers. These 64-bit 
systems can use more virtual and physical memory than 32-bit systems. This allows users work with much larger data 
sets than they could previously, and to analyze and solve large computational problems. Microsoft Office 2010  
introduces a native 64-bit version of Microsoft Excel to take advantage of this larger capacity and now you can use 
Sage 100 ERP Intelligence Reporting with this version too.

NOTE: The option to ‘Use my Outlook Profile’ within the ‘Distribution Settings’ form is not supported when using the 64 
bit edition of Microsoft Outlook 2010. The ‘SMTP / Exchange Server’ option must be used instead.
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Upgrade to Microsoft .NET Framework 4.0

The entire Sage 100 ERP Intelligence Reporting product stack has been moved onto .NET Framework 4.0.

Optimized Installation

For users who already have the .NET Framework 4.0 installed, the installation process for Sage 100 ERP Intelligence 
Reporting is now much faster than before.

Easy Integration with .NET 4.0 Accounting and ERP Systems

Sage 100 ERP Intelligence Reporting can now be integrated with Accounting/ERP systems which have moved onto 
.NET Framework 4.0 without the need for any additional customized integration development.

Smoother Integration with Microsoft Excel

Being on the latest .NET Framework allows Sage 100 ERP Intelligence Reporting to leverage the most stable integra-
tion technologies available for Microsoft Excel, resulting in a better experience inside Excel when using the ‘BI Tools’ 
features.
 

Resolved Issues

License Manager Issues

Wording

The License Manager can be localized to operate with the wording ‘Registration’ instead of ‘Serialization’. In some 
instances the word ‘Serialization’ was discovered to still exist within systems configured to ‘Registration’ localization.

Error When Adding a New Workstation

Previously while adding a new workstation, if the OK button was selected before specifying an option within the 
“Select License Type” window, a Runtime Error ‘94’Invalid Use of Null displayed. This has been resolved by making a 
selection mandatory before selecting OK on this form.

Location: Launch Non-Integrated License Manager > Right Click on first object within object list > Select Add 
Workstation License.
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License Manager Confirmation Pop-up Window

The serialization confirmation pop up is displayed each time after the users serializes their software and not only after 
the first successful serialization.
Location: License Manager > Serialise

Report Designer Row Loading Indicator

In the event of many Row Reporting Groups being selected for use within a Report Designer layout, the ‘edit layout’ 
manager may take a bit longer to load rows giving the impression of a unresponsive form. To avoid this perception, a 
circular progress indicator has been added to the ‘Rows’ section of the Report Designer layout manager and will ap-
pear immediately if the software detects that loading rows will take longer than usual.

Location: Load an existing Report Designer layout via the ‘Launch’ button within BI Tools tab
Location: Quick edit an existing Report Designer layout via BI Tools tab

Distribution Format Spelling

Within a Distribution Instruction is the ability to choose the format that each distribution function must send a report as, 
once of these options was incorrectly listed as MHMTL instead of HTML – this has been corrected.
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Location: BI Tools ribbon tab > Manage Instructions > Edit an Instruction

Add Accounts on a Secondary Monitor

Users are now able to view the Add Accounts pop-up windows on a secondary monitor.

Location: Excel > Add-Ins > Report Tools > Add Accounts

Known Issues

The Report Manager and Connector Ribbon on Windows Vista

Users installing the software on a Windows Vista operating system may experience misplaced ribbon tabs in both the 
Report Manager and Connector. This will result in the tabs being partially cut-off at the top of their screen, the impact 
is minor and therefore may be considered to be resolved in a future release.

Format pivot hangs when Excel is on a secondary monitor 

Users may experience an issue, if they click “format Pivot” whilst Excel is open on a secondary monitor.  The issue 
they will be faced with is Excel will Hang, and then present the user with the below error
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The work around users need to apply is to Format Pivots on their primary screen. Due to the simple work around, the 
issue has been noted to be corrected in a future release. 

Intelligence does not recognize windows resolutions other than standard 100% 

When trying to use a windows resolution greater than 100%. Users will notice that Intelligence is not resizing screen 
based Windows settings, as can be seen below:

To avoid this temporary inconvenience users are encouraged to use a resolution of 100%. This issue has been noted 
for correction in a future release.

Technical Error message when a user attempts to run an Intelligence Report on a 
machine that does not have Excel install

In the event that a User attempts to run out an Intelligence Report on a machine that does not have Excel installed, 
they will be presented with the following message:

Could not load file or assembly ‘ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or 
one of its dependencies. The system cannot find the file specified.
Number: -2147024894
Source: 
Driver Error: Unknown
SQL State: Unknown

We recognize that this error message will not be easily understood by users. We have therefore created a knowledge 
base article to translate the meaning to users. This issue has been noted for correction in a future release.
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