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Introduction 

 

These release notes highlight the differences between and contain important information about usability 

enhancements and resolved issues in Sage 300 ERP 2012 Intelligence Reporting and Sage 300 ERP 

2014 Intelligence Reporting.  The Sage 300 ERP 2014 Intelligence Reporting release is focused on 

features which aim to improve the usability and performance of the solution. 

  

Release Notes 
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New Report Designer 

 
The new Sage Intelligence Report Designer boasts a fresh new user interface to supplement a powerful 
generation engine, utilizing the Report Designer In-Memory technology, allowing for improved 
performance and usability. 
 
You have two methods of creating financial reports using the Report Designer: 

 For novice Excel users, the Sage Intelligence Report Designer Layout Generator is easy to use and 
automates the design of reports layouts quickly and accurately. 

 For intermediate Excel users the Sage Intelligence Report Designer Task Pane is a 100% Excel 
experience and offers maximum control and flexibility over report layouts. 

 

Task Pane 

 
The new Report Designer has incorporated the Task Pane as a report design option for intermediate 
Excel users.  You are able to use the Task Pane to access Chart of Account information and return 
balances from their General Ledger.  Support for alpha-numeric account number ranges has been 
introduced.   

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run 

  

New Features 
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Layout Generator 

 
The Layout Generator has undergone changes to the user interface to improve usability and to support 
the enhancements made to the generation engine, allowing the Layout Generator to run from the  
In-Memory engine, resulting in improved performance. 
 
You will be able to create and edit your layouts in the Layout Design tab.  In order to create a layout you 
will need to configure the following areas: 

 Layout Options – Allows you to specify filters which will apply to the entire layout once generated 
into Excel.  A Reporting Tree is now included as a layout option. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run >  
BI Tools > Quick Edit > Balance Sheet > Layout Options 

 

 Text Columns tab – Provides you with a predefined set of descriptive columns to add to the layout 
design. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run >  
BI Tools > Quick Edit > Balance Sheet > Text columns 

 

 Columns tab – Provides you with a set of predefined columns, based on formulas, to add to the 
layout design in order to return balances from the General Ledger. 
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Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run >  
BI Tools > Quick Edit > Balance Sheet > Columns 

 
 

 Rows tab – Provides you with the ability to select customized rows from the selected Row Set.   

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run >  
BI Tools > Quick Edit > Balance Sheet > Rows 
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You can now create calculated items using the Calculator which has replaced the Formula Builder.   

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run >  
BI Tools > Quick Edit > Balance Sheet > Rows > Add Calculation 

 
 

 
Commonly used layout design functions have been grouped together to improve usability by simplifying 
usage patterns.  The common functions also include the ability to save the layout design.   

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run > 
BI Tools > Quick Edit > Balance Sheet > Rows 
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Row Sets 

 

Row Sets allow you to define customized rows, based on rules using ranges and wildcarding.  The Row 

Set is reusable across all layouts in the report and is centrally managed, reducing the time spent 

customizing and editing rows in reports.  An account rule preview is available to ensure that the rules 

return the correct accounts.  Once a row set has been defined, you are able to use the Row Set within 

your layout design.   

You are able to perform the following actions when managing a Row Set: 

 Add – Adds a new row set. 

 Edit – Edits the selected row set. 

 Rename – Allows users to rename the selected row set. 

 Copy – Allows users to make a copy of the selected row set. 

 Delete – Deletes the selected row set. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run >  
BI Tools > Quick Edit > Balance Sheet > Row Sets 
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You are able to perform the following functions within the Row Set editor: 

 Insert – Inserts a new row below the active row. 

 Clear – Clears the currently selected row. 

 Save – Saves the row set. 

 Help – Opens the Sage Intelligence Help File. 

 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run >  
BI Tools > Quick Edit > Income Statement > Row Sets > Select Row Set 
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New Financial Reports 

Income Statement 

 
The new Financial Income Statement report contains sample Report Designer Income Statement layouts 

to assist you in getting started with your layout design. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run  

 

 

Balance Sheet 

 
The new Financial Balance Sheet report contains sample Report Designer Balance Sheet layouts to 

assist you in getting started with your layout design. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run 
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Financial Ratios 

 
The new Financial Ratios Report contains sample layouts to assist you in calculating and visualizing 

Financial Ratios, in order to make more informed business decisions. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run 

 

 

Financial Forecasting 

 
The new Financial Forecasting report provides you with sample layouts aimed at projecting growth from 

the prior to current year and allows for you to input adjustments in growth percentages.  The Financial 

Forecasting report is for General Ledger only and is based on the standard Sage FR GL Forecasting 

template, “Forecast.xls”.   

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Designer > Demonstration Report Designer > Run 
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Report Manager and Connector Ribbon 

 
The Sage Intelligence Report Manager and Sage Intelligence Connector modules boast a new Ribbon 
feature, with informative icons and labels for each function.  These new icons assist you with easily 
identifying and accessing the features that you require.   
 

Easy Access to Commonly Used Report Manager Features 

 
Report Manager menu items have been restructured and grouped to enable you to easily identify the 
features that you wish to utilize.  Commonly used menu items are now accessible from the ‘Home’ and 
‘Help’ tabs.  All existing functionality and business logic remain as in Sage Intelligence Reporting 7.2.1. 
 
The functions on the Home tab have been grouped into ‘Action’ functions and ‘Report’ functions for ease 
of use.  
 
Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Home 
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Easy Access to Less Commonly Used Report Manager Features 

 
The Report Manager’s less commonly used menu items are now accessible from the ‘File’ and ‘Tools’ 
tabs.    
 
The File tab has been visually aligned to a more familiar interface for a File menu item and existing 
features, such as ‘Configure Internet Connection’ and ‘Metadata Options’ have been grouped for ease of 
use.  Metadata Options allows you to backup Metadata and Templates, change your Metadata 
Repository as well as compact your Metadata to improve performance. 
 
Location: Sage 300 ERP > Intelligence Reporting > Report Manager > File 

 
 
The functions on the Tools tab have been grouped into ‘Report’ functions and ‘System’ functions for 
ease of use.  
 
Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Tools 
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The Report functions grouping on the Tools tab includes the following existing Report Manager features, 
which allow you to perform more advanced management functions in the Report Manager: 

 

 Import Report 

 Export Report 

 Output Mode 

 Toggle Hidden Reports, previously labeled as Show/Hide Hidden reports 

 Scheduler Command 

 Bulk Import/Update 

 Run All Reports, previously labeled as Run Report Batch 

 Clean Pivot fields 

 Clear Report History, previously labeled as Purge Instance History 
 
The System functions grouping on the Tools tab allows you to view System Variables and Unlock Excel. 

 

Easy Access to Commonly Used Connector Features 

 
The Connector module boasts a new Ribbon feature with informative icons and labels for each feature, 

promoting ease of use. 

Connector menu items have been restructured and grouped to allow you to easily identify the features 
you wish to use.  The commonly used menu items are now accessible from the File, Home and Help 
tabs.   
 
Location: Sage 300 ERP > Intelligence Reporting > Connector > Home 

 
 
  



Sage 300 ERP 2014 Intelligence Reporting – Release Notes Page 16 of 32 

 

The Connector File tab has been visually aligned to a familiar interface for a File menu. 
The functions on the Connector File tab have been grouped into ‘Configure Internet Connection’ and 
‘Metadata Options’ functions for ease of use.  
 
Metadata Options allows you to backup Metadata and templates, change their Metadata Repository as 
well as compacting their Metadata to improve performance. 
 
Location: Sage 300 ERP > Intelligence Reporting > Connector > File 

 
 
The Connector Home tab contains further logical grouping of features, including Action functions, 
Expression functions, Data Container functions and Connection Functions.  All icons on the Home tab 
ribbon are visible in windowed mode.   
 
Actions Functions grouping includes basic container and expression management features allowing for 
the ability to: 
 

 Copy  Sample Data  

 Move To  Rename  

 Paste  Delete 

 Check/Test  Refresh 
 
Expression Function grouping includes the ability to perform a Test Lookup for Expressions. 
 
Data Container functions grouping allows users to modify containers’ expressions and includes the 
following existing Connector features: 
 

 Add Expressions 

 Dependencies 

 Find and Replace 

 Check/Test All Expressions 
 
Connection function grouping enables modification of drivers and connections and includes the following 
existing features: 
 

 Add Connection 

 Add Data Container 

 Driver Properties 
 
The Connector Help tab aims to provide the user with informative resources which will guide the 
utilization and promote the understanding of the software.  It contains features from the existing help 
drop down menu: 
 

 View Help 
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 Website 

 Online Academy 

 Knowledge Base 

 About 
 
Location: Sage 300 ERP > Intelligence Reporting > Connector > Help 

 
 

Easy Access to Less Commonly Used Connector Features 

 
The Connector’s less commonly used features are now accessible from the Tools tab in the new 
Connector Ribbon menu.  All icons on the Tools tab ribbon menu are visible in windowed mode.   
The Tools tab functions have been grouped together, and include Report functions and System 
functions. 
 
Location: Sage 300 ERP > Intelligence Reporting > Connector > Tools 

 
 
Report feature grouping contains the existing Import Report feature. 
 
The System feature grouping includes the following existing Connector features: 
  

 Direct Query, previously labeled Direct Query Tool 

 Configure Engine, previously labeled Configure Output Engine 

 System Variables 

 Log File drop down with options Open and Delete 

 Update Metabase  
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Report Manager Context Menus 

 

Folder context right-click menu simplified 

The right-click menus in the Report Manager have been simplified to provide the you with a more 

concise list of options and option labels that are more informative.   

The right-click options ‘Run Report Batch’, ‘Run Report Batch (Mode 2)’, ‘Properties’ and ‘Refresh’ on 
the folder context right-click menu have been removed to help simplify the list of relevant options 
available.  The Refresh feature is still accessible in the Report Manager ribbon via the Home tab and 
Run Report Batch and Run Report Batch (Mode 2) are available under the retitled ‘Run All Reports’ 
option under the Tools ribbon tab. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Home > Right-click any folder  

 

 

Report context right-click menu simplified 

The right-click options ‘Run Sample’ and ‘Refresh’ on the Report context right-click menu have been 

removed and are now accessible in the Report Manager Ribbon via the Home tab.   

The labels ‘Create and Link Template’ and ‘Purge Instance History’ have been replaced by the easily 

understandable labels of ‘Save Excel Template’ and ‘Clear Report History’ respectively.   

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Home > Right-click any folder 
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Usability Improvements 

Report Viewer Usability 

 
Intelligence Reporting includes the following usability enhancements to the Sage Intelligence  

Report Viewer module.   

 The Report Viewer remains open after running a report thereby allowing you to run multiple reports 
without having to reopen the Report Viewer. 

 Report Viewer window size persistence has been introduced. 

 A minimum window size has been enforced to ensure that all available reports are visible. 
 
Location: Sage 300 ERP > Intelligence Reporting > Report Viewer 

 
 

  

Improvements 
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Security Manager 

 
Intelligence Reporting includes an enhancement to the Sage Intelligence Security Manager module to 

display the user input for setting new and updating existing passwords in asterisk and not in plain text. 

Location: Sage 300 ERP > Intelligence Reporting > Security Manager > Add User  
Location: Sage 300 ERP > Intelligence Reporting > Security Manager > Change Password 
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Improve Behavior of Report Property Columns 

 
The tabs which appear when a report is selected within the Report Manager contain table grids to 

display data for columns, filters, parameters, sort fields and aggregate filters.  The columns within these 

grids have been enhanced to automatically resize themselves to ensure they are displaying all text 

values fully.  Previously, if a text value was longer than the default column size it would be cut off, forcing 

a manual resize each time a tab was selected to view the text. 
 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Report > Columns / Filters / Parameters / Sort Fields / 

Aggregate Filters 

 

 

 

 

 

 

 

 

 

 

 

 

Improve Reports Tree Header 

 
Within the Report Manager, the reports listing tree previously displayed a header which was incorrectly 

sized and allowed users to unnecessarily change the width of the viewable tree area.  This header has 

been removed to promote a cleaner user interface and less confusion on how to change the width of the 

viewable tree area. 
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Ability to Rename a Duplicate Container When Importing 

 
When importing a report which contains a Container with the same name as an existing Container, the 

system will now allow the incoming Container to be renamed.  Previously the system would create a 

duplicate named Container, making it challenging to identify the new Container. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Right-click on folder > Import Report 

Location: Sage 300 ERP > Intelligence Reporting > Connector > Right-click on Connection > Import Report 

 
 

Creating Union Reports 

 
The Report ID has been introduced to the user interface to assist you with creating Union reports by 

allowing you to easily and accurately identifying the sub reports used to create Union reports. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Right-click on folder > Add Report > Union Report > 

Enter Report Name > OK 

  

  



Sage 300 ERP 2014 Intelligence Reporting – Release Notes Page 23 of 32 

 

User Interface Modernization 

Replace Configurable Icons with Professional Standard Icons 

 

Certain icons within the system were previously configurable to each implementation, support for 

configuration of these icons has been removed and the icons have been replaced with newer, 

professional looking icons to ensure a consistent look and feel of this application for you regardless of 

which integrated system you are using it with.  Additionally the menu bar and Home node icons have 

been standardized across all modules. 

Location: Sage 300 ERP > Intelligence Reporting > Connector / Report Manager / Report Viewer /License Manager / OLAP 

Manager / Security Manager Windows Taskbar > Module Icons 

 

 
 

Report Manager Background Change 

 

The background of the Report Manager has been updated to promote a more modern and comfortable 

environment and align the system with Sage branding. 

 
Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Run Report 
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Improve Locked Report Properties Panel 

 

The ‘Locked Report’ screen and the ‘Unlock on Copy’ screen have been revamped to present 

information and instructions in a friendly and modern manner.  This purpose of this revamp is to ensure 

that you are not overburdened with information that you do not necessarily wish to see and are 

presented with a professional screen to encourage a more comfortable experience. 

Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Right-click report > Lock Report   
Location: Sage 300 ERP > Intelligence Reporting > Report Manager > Report > Properties Tab > Show Advanced Options > 
Check ‘Unlock on Copy’ > Right-click report > Lock Report 

 

 

Enhanced Report Execution Progress Indicator 

 

A new Progress Indicator has been implemented to replace the older styled moving icon, resulting in a 

more modern look and feel. 
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Modernized BI Tools Report Designer Ribbon 

 

The BI Tools Ribbon has been updated to include new modern icons to improve the consistency and 

familiarity with Microsoft Office.  The Reporting Trees are no longer available from the Ribbon and are 

accessible from the Report Designer Task Pane.  The Mapping Tool and What-if Analyzer features no 

longer apply to the Report Designer and are therefore no longer displayed on the BI Tools ribbon. 

 

 

Multi-language Support 

Excel Components Now Support Multi-language Implementation 

 

All components located under the ‘BI Tools’ tab within Excel (Report Designer, Tools, Distribution) have 

been upgraded to support the implementation of different languages.  Previously these components only 

supported being deployed in English.  This change will significantly decrease the time needed to 

implement this application in different languages.   

NOTE: These Excel components do not yet support implementations of all Unicode languages.  

Currently only French is fully supported, as more languages are implemented and tested – they will be 

fully supported. 

 

Support for Excel 2010 64 Bit Edition 

 

Intelligence Reporting is now compatible with the 64-bit edition of Microsoft Excel 2010.  Processors that 

are 64-bit are becoming the standard for systems that range from servers to desktop computers.   

These 64-bit systems can use more virtual and physical memory than 32-bit systems.  This lets you work 

with much larger data sets than you could previously and to analyze and solve large computational 

problems.  Microsoft Office 2010 introduces a native 64-bit version of Microsoft Excel to take advantage 

of this larger capacity and now you can use Intelligence Reporting with this version too. 

NOTE: The option to ‘Use my Outlook Profile’ within the ‘Distribution Settings’ form is not supported 

when using the 64-bit edition of Microsoft Outlook 2010.  The ‘SMTP / Exchange Server’ option must 

be used instead. 
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Upgrade to Microsoft .NET Framework 4.0 

 

The entire Intelligence Reporting product stack has been moved onto .NET Framework 4.0. 

 

Optimized Installation 

 

If you already have the .NET Framework 4.0 installed, the installation process for Intelligence Reporting 

is now much faster than before. 

 

Easy Integration with .NET 4.0 Accounting and ERP Systems 

 

Intelligence Reporting can now be integrated with Accounting/ERP systems which have moved onto 

.NET Framework 4.0 without the need for any additional customized integration development. 

 

Smoother Integration with Microsoft Excel 

 

Being on the latest .NET Framework allows Intelligence Reporting to leverage the most stable integration 

technologies available for Microsoft Excel, resulting in a better experience inside Excel when using the 

‘BI Tools’ features. 

 

Demonstration Reports 

 

The Intelligence Reporting Demonstration reports have an updated look and feel. 

Location: Sage 300 ERP > Intelligence Reporting > Report manager > Home > Demonstration > Financial Report Designer 2-6 
> Run Financial Report Designer 2-6 
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Location: Sage 300 ERP > Intelligence Reporting > Report manager > Home > Demonstration > Management Pack D-2-6 > 

Run > Management Pack D-2-6  

 

 

Location: Sage 300 ERP > Intelligence Reporting > Report manager > Home > Demonstration > RKL Analysis Dashboard 2-4 
> Run > RKL Analysis Dashboard 2-4  
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Location: Sage 300 ERP > Intelligence Reporting > Report manager > Home > Demonstration > RKL Dashboard 2-3 > Run 

 

 

Location: Sage 300 ERP > Intelligence Reporting > Report manager > Home > Demonstration > Sales Details 2-2 > Run > 

Sales Details 2-2  
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Location: Sage 300 ERP > Intelligence Reporting > Report manager > Home > Demonstration > Stock Re-order Levels 2-2 > 

Run > Stock Re-order Levels 2-2  
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Ability to disable Direct Query Tool 

Security Manager 

Ability to disable access to reports 

You are now able to limit access to reports based on Security Manager Roles.  For more information on 
how to limit access to reports please refer to the Intelligence Reporting Help File. 

Ability to access Security Manager 

You may have experienced an issue when launching the Security Manager module. This has been 

resolved. 

Add Accounts on a Secondary Monitor 

Users making use of the old Financial Report Designer reports are now able to view the Add Accounts 

pop-up windows on a secondary monitor. 

 
Location: Microsoft Excel > Add-Ins Tab > Report Tools > Add Accounts 
 

 

 

License Manager Confirmation pop-up Window 

The serialization confirmation pop-up is displayed each time after you serialize your software and not 

only after the first successful serialization. 

Location: Sage 300 ERP > Intelligence Reporting > License Manager > Serialise 
 

   

 

Resolved Issues 



Sage 300 ERP 2014 Intelligence Reporting – Release Notes Page 31 of 32 

 

Multiple Installations of Microsoft Excel 

You may experience an issue with the loading of the Report Designer Task Pane Excel add-in when 

earlier versions of Excel are installed after later versions of Excel, on the same machine.  You will be 

able to load the Task Pane manually.  For more information on how to manually load the Task Pane 

please refer to the Sage Intelligence Knowledgebase article “Report Designer Task Pane Missing or 

Closed”. 

Balance Drill Down using Account Exclusion rules 

In certain instances where you have made use of an exclusion in your account and Row Set rules, for 

example accounts 1000 TO 2000 – 1090 where account 1090 is the exclusion account, the drill down to 

balance will not omit the exclusion account(s) and will therefore display the exclusion account(s) along 

with the associated balance amount(s). 

Running Reports after Installation 

If you have not installed the software you must launch Excel before running any report in the Designer 

folder, in Report Viewer or Report Manager. 

Running Reports from Report Manager 

When Report Viewer is opened no ‘Open File – Security Warning’ message is displayed as before and 

Report Viewer opens.  The ‘Open File – Security Warning’ message is now displayed before running 

each report in Report Viewer.  Clicking ‘Run’ allows the user to run the report and this has to be done for 

each report the user selects to run. 

Bulk Import for Consolidated Reports 

When upgrading, the Bulk Import feature does not import reports on the consolidation connection.  This 

is as designed.  In order to run consolidation reports for more than one company, please manually import 

the consolidated reports onto the consolidation connection from the Report Update folder. 

  

Known Issues 

http://kb.sageintelligence.com/index.php?title=Report_Designer_Task_Pane_Missing_or_Closed
http://kb.sageintelligence.com/index.php?title=Report_Designer_Task_Pane_Missing_or_Closed
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 Operating Systems: Windows 7 (32 and 64-bit), Windows 8 (32 and 64-bit), Windows server 2008, 
Windows Server 2012 or Windows Terminal Server.   

 Microsoft .Net Framework 4.0 

 Microsoft Excel 2007 and higher 

 Hardware CPU > 1.3 GHz  

 Memory: A minimum of 2 GB RAM is recommended.  This will vary depending on the data volumes 
you are reporting on. 

 Hard Drive Space: 350 MB 

System Requirements 


