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1.1 Introduction 

These release notes contain important information about usability and performance enhancements, including 
resolved issues in Sage Evolution version 7 Intelligence Reporting (previously known as BIC).  The notes 
within this document highlight the changes made between the release of Sage Evolution version 6.82 BIC 
(including the Sage Intelligence Excel Genie), and Sage Evolution version 7 Intelligence Reporting.  This 
Intelligence Reporting release incorporates the Sage Intelligence Report Designer Add-In into Intelligence 
Reporting software and is focused on features which aim to improve the usability and performance of the 
solution. 

 

1.0 Release Notes 
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The Sage Intelligence Report Manager module boasts a new Ribbon feature with informative icons and labels 
for each function, aiding the user in easily identifying and accessing the features that they require.   

 

2.1 Easy access to commonly used Report Manager features 

The Report Manager menu items have been restructured and grouped to enable users to easily identify the 
features that they wish to utilize.  Commonly used menu items are now accessible from the Home and Help 
tabs.  All existing functionality and business logic remain the same, as in Sage Evolution 6.82 Intelligence 
Reporting. 

The Home tab contains further logical grouping of features, including Action functions and Report functions.   

Location: Report Manager > Home 

 

 

The ‘Actions’ grouping contains functions that allow the user to manage reports within the Report Manager 
module and include the following existing Report Manager features: 

 Copy 
 Paste 

 Move To 

 Add Folder 

 Add Report 

 Rename 

 Delete 

 Refresh 
 

The Report grouping has functions that allow users to perform operations on reports within the Report 
Manager module and includes the following existing features: 

 Run 

 Run Sample 

 Lock/Unlock Report 

 Design 

 Save Excel Template 

 Check/Test 

 Create Shortcut 

 History 
 
  

2.0 New Features 
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All icons on the Home tab ribbon are visible in windowed mode. 

Location: Report Manager > Home 

 

 

The Help tab contains features from the existing help drop-down menu, which are aimed at assisting the user 
by directing them to the help file and online communities, and providing information on the product: 

 View Help 

 Website 

 Online Academy 

 Knowledge Base 

 About  
 

Location: Report Manager > Help 
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2.2 Easy access to less commonly used Report Manager features 

The Report Manager’s less commonly used menu items are now accessible from the File and Tools tabs.     

The File tab has been visually aligned to a more familiar interface for a File menu item, and contains further 
logical grouping of existing features, including Configure Internet Connection and Metadata Options.  
Metadata Options allows the user to backup Metadata and Templates, as well as compacting their Metadata 
to improve performance. 

 

Location: Report Manager > File 

 

 

The Tools tab contains logical grouping of features, including Report functions and System functions.  All 
icons on the Tools tab ribbon are visible in windowed mode. 

 

Location: Report Manager > Tools 
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The Report functions grouping on the Tools tab includes the following existing Report Manager features which 
allow the user to perform more advanced management functions in the Report Manager: 

 Import Report 

 Export Report 

 Output Mode 

 Toggle Hidden Reports, previously labeled as Show/Hide Hidden reports  

 Scheduler Command 

 Bulk Import/Update 

 Run All Reports, previously labeled as Run Report Batch 

 Clean Pivot fields 

 Clear Report History, previously labeled as Purge Instance History 
 

The System functions grouping on the Tools tab allows users to view System Variables as well as unlock 
Microsoft® Excel®. 

 

2.3 Easy Access to Commonly Used Sage Intelligence Connector (previously known as 
Administrator) Features 

The Connector module boasts a new Ribbon feature with informative icons and labels for each feature 
promoting ease of use. 

Connector Menu items have been restructured and grouped to allow users to more easily identify the features 
they wish to use.  The more commonly used menu items are now accessible from the File, Home and Help 
tabs.    

 

Location: Connector > Home 
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The Connector File tab has been visually aligned to a more familiar interface for a File menu and contains 
logical grouping of existing features including Configure Internet Connection and Metadata Options.  
Metadata Options allows the user to Backup Metadata and Templates, as well as compacting their Metadata 
to improve performance. 

Location: Connector > File 

 

 

The Connector Home tab contains logical grouping of features, including Action functions, Expression 
functions, Data Container functions and Connection functions.  All icons on the Home tab ribbon are visible in 
windowed mode.   

 

Action function grouping includes basic container and expression management features allowing for the ability 
to: 

 Copy 

 Sample Data  

 Move To 

 Rename  

 Paste 

 Delete 

 Check/Test 

 Refresh 
 

Expression function grouping includes the ability to perform a test lookup for Expressions. 

 

Data Container function grouping allows users to modify a container’s expressions and includes the following 
existing Connector features: 

 Add Expressions 

 Dependencies 

 Find and Replace 

 Check/Test All Expressions 
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Connection function grouping enables modification of drivers and connections and includes the following 
existing features: 

 Add Connection 

 Add Data Container 

 Driver Properties 
 

The Connector Help tab aims to provide the user with informative resources which will guide the utilization 
and promote the understanding of the software.  It contains features from the existing help drop-down menu: 

 View Help 

 Website 

 Online Academy 

 Knowledge Base 

 About 
 

Location: Connector > Help 

 

 

2.4 Easy access to less commonly used Connector features 

The Connector’s less commonly used features are now accessible from the Tools tab in the new Connector 
Ribbon menu.  All icons on the Tools tab ribbon menu are visible in windowed mode.  The Tools tab contains 
logical grouping of features, including Report functions and System functions which facilitate more advanced 
management within the Connector Module. 

Location: Connector > Tools 
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Report feature grouping contains the existing Import Report feature. 

The System feature grouping includes the following existing Connector features: 

 Direct Query, previously labelled Direct Query Tool 

 Configure Engine, previously labelled Configure Output Engine   

 System Variables 

 Log File drop-down with options Open and Delete. 

 Update Metabase 

 

2.5 The Report Designer  

The Report Designer has replaced the functionality of the BIC Excel Genie.  The Report Designer boasts a 
fresh User Interface to compliment the powerful generation engine utilizing the Report Designer Add-In In-
Memory technology allowing for improved performance and usability. 

Users have two methods of creating financial reports using the Report Designer: 

 For intermediate Excel users the Task Pane is a 100% excel experience and offers maximum control 
and flexibility over report layouts  

 For novice Excel users the Layout Generator is easy to use and automates the design of reports 
layouts quickly and accurately. 

Task Pane 

The new Report Designer has incorporated the Report Designer Add-In Task Pane as an option for 
intermediate Excel users.  Users are able to use the Task Pane to access Chart of Account information and 
return balances from their General Ledger.   

Location: Report Manager > Report Designer > Run 
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2.6 Layout Generator 

The Layout Generator has undergone changes to the user interface to improve usability.  Enhancements 
have been made to the generation engine allowing the Layout Generator to run from the In-Memory Database 
resulting in improved performance.  The Layout Generator creates layouts using formulas that are accessible 
from the Task Pane empowering users to easily and dynamically update and modify their layouts once 
generated into Excel. 

 

 

Users will be able to create and edit their layouts in the Layout Design tab.  In order to create a layout, users 
will need to configure the following areas: 

Layout Options allows users to specify filters which will apply to the entire layout once generated into Excel.  
Reporting Tree Unit is now included as a layout option.   

Location: Report Manager > Report Designer > Run > BI Tools > Quick Edit > Balance Sheet > Layout 
Options 
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Text Columns tab provides users with a predefined set of descriptive columns to add to the layout design. 
 

 
 

Columns provides users with pre-defined columns based on formulas to add to the layout design, in order to 
return balances from the General Ledger. 
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Rows provide users to select their customized rows from the selected row set. 
 

 
 

Users can create calculated items using the Calculator which has replaced the Formula Builder.    
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Commonly used layout design functions have been grouped together to improve usability by simplifying 
usage patterns.  The common functions also include the ability to save the Layout Design.  

 
  



  
 
 

Sage Evolution 7 Intelligence Reporting – Release Notes Page 16 of 28  
 
 

2.7 Row Sets 

Rows sets allow the ability to create rules based on Account (GL account number) or GL Category 
Code.   

Row Sets allow users to define customized rows based on rules.  The row set is reusable across all 
layouts in the report and is centrally managed, reducing the time spent customizing and editing rows in 
reports.  A rule preview is available to ensure that the rules return the correct accounts.  Once a row set 
has been defined, users can select to use the row set within their layout design.   

Users are able to perform the following actions when managing a row set: 

 Add – Adds a new row set 

 Edit – Edits the selected row set 

 Rename – Allows users to rename the selected row set 

 Copy – Allows users to make a copy of the selected row set 

 Delete – Deletes the selected row set 

 

Location: Report Manager > Report Designer > Run > BI Tools > Quick Edit > Balance Sheet > Row 
Sets 
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Users are able to perform the following functions within the row set editor: 

 Insert – Inserts a new row below the active row 

 Clear – Clears the currently selected row 

 Save – Saves the row set 

 Help – Opens the Sage Intelligence Help File 

 

Location: Report Manager > Report Designer > Run > BI Tools > Quick Edit > Balance Sheet > Row 
Sets 

 

 

2.8 Look and Feel of the Generated Layout 

The look and feel of the layouts generated by the Layout Generator tool has been updated to a more modern 
and simplistic style. 

 

Location: Report Manager > Report Designer > Run > task pane > “Selected layout” 
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2.9 Missing Accounts  

Sage Intelligence Reporting has introduced a new feature which allows you to view the accounts that are 
missing from your entire report or from the current layout compared to the accounts that exist in the general 
ledger which has been retrieved by the In-Memory database. 

 

Location: Report Manager > Report Designer > Run > task pane > tools 

 

 

 

Clicking the dropdown will show the available options to view missing accounts.   

 

 

Once a selection has been made, a message will appear keeping the user informed as to whether missing 
accounts where found, or if there are no accounts missing.   

 

2.10 Support for multiple Report Designer configuration 

The Report Designer now has the ability to function with multiple versions of the same ERP/Accounting 
system configuration as well as multiple configurations for different ERPs or accounting systems in the same 
environment.   

This will improve the users upgrade experience as it will enable them to use all of their pre-existing report 
designer reports without any issues after upgrading to the latest version to take advantage of the new 
features and enhancements. 

It will also benefit Business Partners who run different versions of Intelligence Reporting on the same 
environment who will now be able to switch between different report designer workbooks without experiencing 
any issues. 
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2.11 Ability to generate Layouts from the Task Pane 

Users are now able to generate layouts from the Task Pane by simply dragging the layout into a blank sheet 
in Excel.  This provides an out the box reporting experience. 

 

Location: Report Manager > Report Designer > Run > task pane > “Selected Report” 

 

 

Users are not required to perform any additional setup or mapping of accounts prior to running their pre-
defined financial layouts from either the Task Pane or the Layout Generator as the Row Set feature has been 
enhanced to allow rows based on fixed account categories that have been set up in their ERP or Accounting 
system. 

 

Location: Report Manager > Report Designer > Run > BI tools > Quick Edit > Rowsets 

 

 

 

 

 

2.12 Manage Layouts 
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Users are now able to launch the Manage Layouts screen from the Task Pane.  This allows users the 
opportunity to customise layouts to their specifications directly from the task pane.   

 

Location: Report Manager > Report Designer > Run > task pane > Layouts > Manage 

 

 

2.13 Folder context right-click menu simplified 

The right-click menus in the Report Manager have been simplified to provide the user with a more concise list 
of options as well as option labels that are more informative.   

The right-click options “Run Report Batch”, “Run Report Batch (Mode 2)”, “Properties” and “Refresh” on the 
folder context right-click menu have been removed to help simplify the list of relevant options available.  The 
“Refresh” feature is still accessible in the Report Manager ribbon via the Home tab and “Run Report Batch” 
and “Run Report Batch (Mode 2)” are available under the retitled ‘Run All Reports’ option under the Tools 
ribbon tab. 

 

Location: Report Manager > Home > Right-click any folder  
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3.1 Report Designer  

 Report designer performance  

Sage Intelligence Reporting has an enhanced Report Designer module with the ability to transpose data when 
loading the data from the Excel source sheets into the In-Memory Database.  As a result the container 
queries which underlie the Report Designer reports are greatly simplified for ERP’s with column-based 
General Ledger database structures.  This greatly improves the performance of running out the report into 
Excel.   

 

 

 Improved User Experience when Reporting on Large Data Volumes 

The Report Designer uses In-Memory caching to ensure high performance when designing financial layouts 
in Excel.  In-memory caching makes use of the available RAM and when reporting on large data volumes the 
resulting RAM usage can be high.  The Report Designer has been enhanced to actively monitor the RAM 
usage of the In-Memory Database to ensure that it never exceeds a level which will result in Excel becoming 
unresponsive or running out of Memory.  This is particularly beneficial when working with large data volumes 
and ensures that the experience of designing excel-based financial reports based on such data is greatly 
improved. 

 

 Improved support for Account Segment Separators 

Some ERPs which have segmented General Ledgers support a variety of account segment separators.  This 
means that their account numbers may look as follows: 

 

3.0 Improvements 
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The Report Designer has been extended to support the following account segment separators allowing for a 
more consistent experience when reporting in Excel. 

  

 - (Dash) 

 / (Slash) 

 \ (Backslash) 

 .  (Full stop) 

 # (Number sign) 

 % (Percentage) 

 ^(Caret) 

 & (Ampersand) 

 : (Colon) 

 < (Greater than) 

 > (Less than) 

 *  (Asterisk) 
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3.2 Report context right-click menu simplified 

The right-click options “Run Sample” and “Refresh” on the report context right-click menu have been removed 
and are now accessible in the Report Manager Ribbon via the Home tab.   

The labels ‘Create and Link Template’ and ‘Purge Instance History’ have been replaced by less technical and 
therefore more easily understandable labels of ‘Save Excel Template’ and ‘Clear Report History’ respectively.   

Location: Report manager > Home > Right-click any folder 
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3.3 Report Manager Date Selector 

The Report Manager Date Selector has an improved look and feel. 

Location: Report Manager > Home > Select folder > Select report > Run 

 

 

3.4 Modernized run report background 

The background of the run report menu has been updated to reflect the modern theme that has been applied 
to the reports. 
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3.5 Modernized BI Tools Report Designer Ribbon 

The BI Tools Ribbon has been updated to include new modern icons to improve the consistency and 
familiarity with Microsoft Office.  The Reporting Trees are no longer available from the Ribbon and are 
accessible from the Report Designer Task Pane.  The Mapping Tool and What-if Analyzer features no longer 
apply to the Report Designer and are therefore no longer displayed on the BI tools ribbon. 

Location: Report Manager > Designer > Select Designer Report (Applicable to integrated versions of the 
software only) > Run 

 

 

3.6 Creating Union Reports 

The Report ID has been introduced to the user interface aiding users in creating union reports by allowing 
users to easily and accurately identifying the sub reports used to create Union Reports. 

Location: Report Manager > Select Folder > Add Report > Union Report > Enter Name 
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4.1 Connector Shortcuts 

The following keyboard shortcuts resulted in an error and are now supported in the Connector module: 

 

Shortcut Keyboard Shortcut  Applies to 

Copy CTRL-C  Text from a textbox 

 Container object 

 Expression object 

Paste. CTRL-V  Text onto a textbox 

 Container onto a connection  

 Expression onto a container 

Properties CTRL-O  Connection Type 

 Connection 

 Container 

 Expression 

Add child to object selected. F12  Connection Type - to add 
connection 

 Connection - to add container 

 Container - to add expression 

Rename. F2  Connection Type 

 Connection 

 Container 

 Expression 

Refresh F5  All Features 

  

4.2 Right-click context menu 

The following right-click options in the Report Manager resulted in 
unexpected behavior as a result of the simplified right-click context 
menu.  This issue has been resolved. 

 

Location: Report Manager > Add Sub Query Report 

Location: Report Manager > Add Dataless Report 

 

 

 

 

 

 

 

 

4.0 Resolved Issues 
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4.3 Connector Ribbon: Check-Testing All Expressions 

The option to Check/Test All Expressions under the Home tab in the Connector module now performs a 
check/test operation on all expressions associated with the selected container and not only on the selected 
container. 

Location: Connector > Home Tab > Check/Test All Expressions 
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5.1 Multiple Installations of Microsoft Excel 

Users may experience an issue with the loading of the Report Designer Task Pane Excel Add-in when earlier 
versions of Excel are installed after later versions of Excel, on the same machine.  Users will be able to load 
the add-in manually.  For more information how to manually load the add-in please refer to the Sage 

Intelligence Knowledge Base article “Report Designer Task Pane Missing or Closed”. 

 

5.2 Balance Drill Down using Account Exclusion rules 

In certain instances where users have made use of an exclusion in their account and row set rules, for 
example accounts 1000 TO 2000 – 1090 where account 1090 is the exclusion account, the drill down to 
balance will not omit the exclusion account(s) and will therefore display the exclusion account(s) along with 
the associated balance amount(s). 

 

5.3 Running Reports after Installation 

Users who have not installed the software must launch Excel before running any report in the Designer folder, 
in Report Viewer or Report Manager. 

 

5.4 Drill Down on cells containing more than two nested formulas 

Users will receive a “Drill Down Problem!” notification when attempting to drill down on a cell which contains 
more than two nested formulas. 

For example: 

AnGLBudgetYTDX3(,,,,,GLCurrentYearX3("001"),GLCurrentPeriodX3("001"),,,,,,H20). 

Users will need to replace the nested formula with either a cell reference, or with a written value.   

 

5.5 Dragging a Task Pane Layout into Excel 

Dragging a Task Pane Layout into Excel will overwrite the cell to which the user drags the layout despite that 
the action will generate the layout in a new worksheet.  We therefore advise dragging in a layout into a blank 
worksheet. 

 

 

 

 

 

 

5.0 Known Issues 

http://kb.sageintelligence.com/index.php?title=Report_Designer_Task_Pane_Missing_or_Closed

